Introduction
Action Script Replacer est un utilitaire Win32 vous permettant de remplacer les ActionScript dans les animations Flash (fichiers SWF).

Action Script Replacer

Avec ASR vous pouvez :
  • Voir tous les scripts d'un fichier SWF. (SWF versions 6 et précédentes, fichiers SWF générés avec Flash MX, 5, 4, 3 supportés)
  • Remplacer n'importe quel script avec un autre script compatible résidant dans n'importe quel autre fichier SWF.
  • Insérer/Apposer une image ActionScript à n'importe quelle image sur n'importe quel scénario.
  • Apposer une image à n'importe quel scénario.
  • Changer l'ordre des actions InitClip.
De plus :
  • Vous pouvez voir et modifier les propriétés de base d'une animation (comme la cadence, la couleur de fond, etc.).
  • Vous pouvez visionner les scripts en P-code (la source en code octet).
  • ASR utilise le même moteur de décompilation qu'Action Script Viewer.
  • Vous pouvez ouvrir des fichiers SWF imbriqués dans des projecteurs ou d'autres fichiers EXE.
Afin d'éviter toute mauvaise interprétation, avec ASR :
  • Vous ne pouvez pas supprimer des ActionScript (mais vous pouvez remplacer un script avec un script vide).
  • Vous ne pouvez pas ajouter un bouton ou une action clip/script de clip d'animation (vous ne pouvez modifier que les scripts existants en les remplaçant et vous ne pouvez ajouter des scripts qu'aux images).
  • Vous ne pouvez pas enregistrer un SWF au format EXE, s'il s'agissait du format d'origine (vous ne pouvez qu'enregistrer le SWF modifié sous un fichier SWF indépendant).


Installation
Copiez tous les fichiers du zip dans un dossier et lancez ASR10.EXE (ASR n'a pas d'installeur/désinstalleur et nous considérons cela comme un avantage).

ASR 1.0 requiert un fichier clé de licence personnelle pour démarrer. Si le zip que vous avez reçu ou téléchargé ne contient pas le fichier ASR10.PKE, vous devez aussi copier ce fichier (qui vous a été envoyé séparément) dans le même dossier. Sinon, ASR ne démarrera pas.

Notes :
Pour voir l'aperçu dans la fenêtre de sélection / insertion de script vous avez besoin d'avoir le plug-in ActiveX Flash OCX installé.

ASR fonctionne et a été testé sur Microsoft Windows 95/98/ME/NT/2000 et XP. ASR 1.0 supporte les fichiers SWF versions 6 (MX) et précédentes.

ASR n'écrit rien dans la base de registre de Windows, et ne crée aucun autre fichier que ceux mentionnés dans la section Désinstallation ci-dessous.

ASR n'essaye pas de se connecter à Internet pour envoyer ou recevoir de quelconques données. Toutefois, le lecteur ActiveX Shockwave Flash utilisé pour l'aperçu peut être amené à le faire.

Désinstallation
Supprimez les fichiers que vous avez copiés et aussi le fichier ASR10.INI qu'ASR crée lors de son premier démarrage. Il n'y a aucun désinstalleur fourni.


Nouveautés
Version 1.02
  • Mise à jour du moteur de décompilation.
Version 1.01
  • Mise à jour du moteur de décompilation.
  • L'option permettant d'afficher certains fichiers brouillés est sélectionnée par défaut.
  • L'option permettant de visualiser les P-codes en un format Flasm plus lisible est sélectionnée par défaut.


Utilisation
Vous pouvez ouvrir un fichier SWF, soit en utilisant la commande Ouvrir du menu Fichier ou de la barre d'outils, soit en glissant/déposant un fichier SWF dans la fenêtre d'ASR.

Vous pouvez aussi ouvrir des fichiers SWF imbriqués dans des projecteurs ou dans d'autres fichiers EXE.

(Il faut savoir que pour certains fichiers SWF, la plupart du temps produits ou modifiés par des applications de tierce partie, des erreurs ou des avertissements seront affichés. Après les avoir modifiés et sauvés, assurez-vous de tester ces fichiers).

Tous les scripts du SWF seront listés.

Quand vous sélectionnez un script, les ActionScript décompilés sont affichés en bas. Vous pouvez sélectionner des options permettant de paramétrer la façon dont ces ActionScript sont affichés en utilisant le menu Options.

Vous pouvez :
  • Remplacer un ActionScript (voir ci-dessous).
  • Insérer/Apposer un script d'image à n'importe quelle image (voir ci-dessous).
  • Apposer une image à n'importe quel scénario (voir Fenêtre d'insertion de script d'image).
  • Changer l'ordre des actions InitClip (voir Menu Actions).
Enregistrez le SWF une fois que vous avez terminé. ASR vous avertira si le SWF a été modifié mais qu'il n'a pas été sauvegardé quand vous fermerez l'application.

Comment remplacer un ActionScript
  1. Sélectionnez l'ActionScript à changer.
  2. Cliquez sur le bouton Remplacer le script de la barre d'outils (ou choisissez la commande dans le menu Actions).
  3. Sélectionnez le fichier SWF contenant l'ActionScript désiré. Ce fichier SWF doit avoir été préparé à l'avance (voir ci-dessous).
  4. La Fenêtre de sélection de script sera affichée et les ActionScript compatibles y seront listés. Sélectionnez le script désiré et cliquez sur le bouton OK pour remplacer le script.
  • Afin d'éviter tout problème d'incompatiblité, il est recommandé que le fichier SWF source soit de la même version SWF que le fichier actuel. Vous pouvez simplement copier le script sélectionné (F9), le coller dans Flash, effectuer vos modifications, puis l'exporter dans la même version SWF (visible dans la Fenêtre d'informations sur l'animation).
  • Quand vous remplacez des actions d'image, le SWF source doit contenir des actions d'image. Pour arriver à ce résultat, vous pouvez créer une nouvelle animation dans Flash, y ajouter les actions désirées à n'importe quelle image, puis exporter le SWF.
  • Quand vous remplacez des actions de bouton, le SWF source doit contenir un bouton avec des actions. Vous pouvez créer un nouveau bouton dans Flash, en placer une instance dans le scénario, et y ajouter les actions désirées. Cependant, si le bouton sélectionné est de Type 1, indiqué par l'icône [image], qui ne peut avoir qu'un évènement on(release), le nouveau bouton doit aussi avoir des actions pour l'évènement on(release).
  • Quand vous remplacez des actions de clip, le SWF source doit contenir un clip d'animation avec des actions de clip. Vous pouvez créer un nouveau clip d'animation dans Flash, en placer une instance dans le scénario, et y ajouter les actions désirées (dans un groupe onClipEvent() ).
  • Quand vous remplacez des actions InitClip, le SWF sélectionné doit contenir soit des actions d'image, soit des actions InitClip, qui sont compatibles. Il sera plus facile de créer des actions d'image dans Flash. (Si vous créez des actions InitClip, seul le corps du script sera utilisé, le pragma #initclip et le paramètre d'ordre seront ignorés). Après avoir remplacé le script, vous pourrez changer le paramètre d'ordre en utilisant les commandes Déplacer l'action InitClip vers le haut/vers le bas.
  • Les paramètres des composants sont affichés comme des actions de clip (comme label = "Case à cocher";), car c'est la façon dont ils sont implémentés dans le format SWF. Ces actions sont rassemblées dans des blocs "Start Component Parameters" .. "End Component Parameters" (dans le texte de l'ActionScript décompilé), que l'éditeur de script de Flash ne reconnaît pas. Pour pouvoir remplacer des paramètres de composants, vous devez créer un fichier SWF contenant un symbole composant ayant les paramètres désirés. Ensuite, dans la Fenêtre de sélection de script, ces paramètres seront à nouveau affichés comme des actions de clip, disponibles pour le remplacement des paramètres de composants actuels.
Comment insérer un script d'image
  1. Cliquez sur le bouton Insérer un script d'image de la barre d'outils (ou choisissez la commande dans le menu Actions).
  2. La Fenêtre d'insertion de script d'image sera alors affichée. Sélectionnez le scénario et l'image dans laquelle le script doit être inséré.
  3. Cliquez sur le bouton "Suivant" et sélectionnez le fichier SWF contenant les scripts d'images désirés. Ce fichier SWF doit avoir été préparé à l'avance.
  4. La Fenêtre de sélection de script sera alors affichée et les ActionScript compatibles y seront listés.
  5. Sélectionnez le script désiré, et cliquez sur le bouton "OK". Le script sera inséré dans l'image et ajouté à la liste des actions principales.


Menus
Menu Fichier
Ouvrir (F3) | Affiche la fenêtre d'ouverture de fichier pour ouvrir un fichier SWF.
Enregistrer sous (F2) | Demande un nom de fichier et vous permet de sauvegarder le SWF actuel.
Propriétés de l'animation (F6) | Affiche la Fenêtre d'informations sur l'animation.
[Les 4 fichiers les plus récemment utilisés] | En sélectionnant un nom de fichier vous ouvrirez le fichier associé.
Quitter | Termine ASR. Si le SWF ouvert a été modifié, il vous sera demandé de confirmer cette action.

Menu Actions
Remplacer le script (ALT+R) | Vous permet de sélectionner un fichier SWF, puis de choisir un script compatible dans ce fichier afin de remplacer l'ActionScript actuellement sélectionné.
Insérer un script d'image (ALT+I) | Affiche la Fenêtre d'insertion de script d'image.
Déplacer l'action InitClip vers le haut
Déplacer l'action InitClip vers le bas 		Les actions InitClip sont utilisées pour les inistialisations uniques des clips d'animations ou des composants. Dans Flash, elles sont entrées dans la première image d'un clip d'animation, entre les actions #initclip #endinitclip. Quand il y a plusieurs actions InitClip, l'ordre d'exécution est déterminé par le paramètre Ordre de l'action #initclip. Cependant, quand le fichier SWF est exporté, ce paramètre n'est pas préservé en tant que nombre ; il déterminé juste l'ordre dans lequel les scripts sont placés dans le fichier.

Quand ASR décompile ces scripts, un paramètre est associé à l'action #initclip afin de respecter l'ordre dans le fichier. Vous ne pouvez pas éditer directement ce paramètre ou en le remplaçant, mais vous pouvez changer l'ordre, and utilisant les commandes "... vers le haut" et "... vers le bas". Ces boutons sont activés quand des actions initclip sont sélectionnées. Utiliser la commande de montée pour décrémenter la valeur du paramètre ordre, et la commande de descente pour l'incrémenter. (Vous ne pouvez pas décrémenter l'odre pour #initclip 1, ni incrémenter l'ordre du dernier#initclip).

Menu Options
Changer la police... (CTRL+ALT+F) | Affiche la fenêtre Police et vous permet de changer la police.
Retour à la ligne auto. (CTRL+W) | (Dés)Activer le retour à la ligne automatique.
Afficher les scripts longs (CTRL+G) | Quand cette option est activée, les ActionScript sont complètement décompilés et affichés. Sinon, seules quelques lignes de chacun des scripts seront affichées.
Coloriser (CTRL+ALT+Z) | (Dés)Activer la colorisation des ActionScript.
Activer le mode \u (CTRL+ALT+U) | (Dés)Active le mode \u. Quand le mode \u est activé, ASR affiche les caractères non-ASCII en tant que séquences d'échappement \u. Sinon, les caractères introuvables dans la police actuelle sont remplacés par des points d'interrogation (?). Cette option n'est disponible que pour les fichiers SWF version 6 (et versions ultérieures).
Afficher la source en P-code (F11) | Les ActionScript des fichiers SWF sont actuellement stockés comme un flux d'actions simples que le lecteur Flash interprère, et qu'ASR décompile en ActionScript lisible. Cette option est fournie au cas où vous auriez besoin de voir les actions originales.

Menu Aide
Contenu (F1) | Affiche le contenu de l'aide (ce fichier).
A propos | Affiche la fenêtre A propos, où vous pouvez voir des informations sur la version du produit et l'utilisateur enregistré.


Fenêtre de sélection de script
Cette fenêtre vous permet de sélectionner un ActionScript depuis un fichier SWF.

Les ActionScript compatibles trouvés dans le SWF sont listés au début. Il y a quatre types de scripts dans un fichier SWF :
  • Action d'image : Se comporte comme une image, dans le scénario principal ou dans celui d'un clip d'animation.
  • Action de bouton : Action associée avec des évènements de boutons. (Les boutons qui ne supportent que les actions on(Release) sont indiqués avec l'icône [image]).
  • Action de clip : Action associée avec les évènements des clips d'animations.
  • Action InitClip : Action qui initialise un clip d'animation. Dans Flash, ces actions sont entrées dans la première image d'un clip d'animation dans un pragma #initclip.
Le script sélectionné sera décompilé et affiché dans la zone de texte du bas. Les options de visualisation ActionScript de la fenêtre principale s'appliquent aussi ici.

Après avoir sélectionné le script désiré, cliquez sur le bouton OK pour confirmer, ou sur le bouton Annuler pour annuler l'opération.


Fenêtre d'insertion de script d'image
Cette fenêtre vous permet de sélectionner une image afin d'y insérer un script. Vous pouvez aussi apposer des images à n'importe quel scénario.

Vous pouvez sélectionner le scénario dans la liste déroulante (le scénario principal ou celui d'un clip d'animation). Les images du scénario sélectionné sont listées en-dessous.

Les images contenant déjà des actions sont indiquées par une icône action : .

Vous pouvez sélectionner une image existante, ou apposer une nouvelle image et la sélectionner. Un aperçu de l'image sélectionnée sera alors affiché, toutefois les ActionScript sont désactivés dans cette fenêtre et cet aperçu est surtout destiné à identifier les symboles.

Apposition d'image
Cliquez sur le bouton afin d'ajouter une nouvelle image à la fin. Cette image contiendra toujours les symboles de la dernière image. Pour ajouter une image vide, sélectionnez la case à cocher avant de cliquez sur le bouton.

Bouton Suivant
Ce bouton est activé après qu'une image ait été sélectionnée. Cliquez dessus pour continuer et ouvrir un fichier SWF, puis sélectionnez le script à insérer. Si l'image sélectionnée contient déjà des actions, le nouveau script sera apposé au script existant.

Bouton Fermer
Cliquez sur ce bouton pour annuler l'insertion d'un script. Toutefois, si vous avez ajouté de nouvelles images, elles ne seront pas supprimées.


Fenêtre d'informations sur l'animation
Les propriétés principales de l'animation sont affichées dans cette fenêtre.

Emplacement :
Emplacement de l'animation SWF sur le disque.

Vous pouvez sélectionner et copier le contenu de l'emplacement en utilisant le menu contextuel ou le clavier.

Version SWF :
Version du fichier SWF. ASR 1.0 supporte les versions SWF 6 et précédentes.

Compressée :
Affiche si l'animation SWF est compressée ou non .

Si le fichier est compressé, cliquez sur le texte "détails" pour faire apparaître une boîte de dialogue affichant la taille du fichier sur le disque, sa taille non compressée et l'algorythme de compression.

Si le fichier n'est pas compressé, la taille du fichiers en octets est affichée entre parenthèses.

Largeur :
Largeur de l'animation SWF en pixels.

Hauteur :
Hauteur de l'animation SWF en pixels.

Cadence :
Cadence de l'animation SWF en ips (images par seconde).

Images :
Nombre total d'images de l'animation SWF.

Couleur de fond :
La couleur de fond de l'animation SWF est affichée en hexadécimal (compatible HTML). Un aperçu de la couleur apparaît aussi dans un rectangle noir.

Limites :
Limites de l'animation SWF en coordonnées pixels (gauche, haut)(droite, bas). Si les premières coordonnées sont (0,0) alors les secondes coordonnées seront (largeur, hauteur).

Centre :
Coordonnées du centre de l'animation SWF, calculées à partir des coordonnées des limites de celle-ci.

Bouton Modifier
Ce bouton affiche la Fenêtre de modification d'animation.


Fenêtre de modification d'animation
Vous pouvez modifier les limites (largeur, hauteur), la cadence et la couleur de fond de l'animation SWF grâce à cette fenêtre.

Limites
Les coordonnées des limites sont affichées et peuvent être modifiées. En même temps que vous éditez ces valeurs, les nouvelles propriétés de largeur, hauteur et centre sont mises à jour en temps réel. Vous pouvez restaurer les valeurs originales en utilisant le bouton rétablir.

Cadence
La cadence actuelle de l'animation en ips (images par seconde) est affichée ; vous pouvez la modifier ou restaurer la valeur originale en utilisant le bouton rétablir.

Note : si vous entrez une valeur décimale, celle-ci sera sans doute arrondie à cause des limitations du format SWF.

Couleur de fond
La couleur de fond est affichée en hexadécimal et en aperçu dans un rectangle noir. Vous pouvez éditer cette valeur ou cliquez sur l'aperçu et choisir une couleur. Le bouton rétablir vous permet de restaurer la valeur d'origine.


Fenêtre de sélection SWF
Quand vous ouvrez un fichier non-SWF avec ASR, que ce soit en utilisant la fenêtre d'ouverture de fichier ou en le glissant/déposant, ASR recherche et essaye de trouver un fichier SWF imbriqué dans le fichier.

Note : Quand ASR effectue une recherche dans un fichier, il cherche une signature SWF. Il est possible que le fichier trouvé ne soit pas du tout un SWF.

Si aucun fichier SWF n'est trouvé, une boîte de dialogue "Fichier SWF introuvable !" est affichée.

Si seulement un candidat SWF est trouvé, il est ouvert.

Notez aussi qu'ASR ne peut pas enregistrer le SWF modifié dans le fichier EXE.

Si plus d'un candidat SWF est trouvé, la "Fenêtre de sélection SWF" est affichée.

En haut, le nom du fichier est affiché.

Dans la liste sont affichés la version SWF, la longueur et l'offset dans le fichier.

Bouton Ouvrir
Ouvre le candidat SWF sélectionné. Le dernier fichier SWF extrait est enregistré sous "EXTRACTED.SWF" dans le même dossier que l'exécutable principal d'ASR.

Bouton Aperçu
Ouvre le candidat SWF sélectionné avec l'application associée aux fichiers SWF. (Si vous avez installé Macromedia Flash, ce devrait être le lecteur Flash).

Bouton Annuler
Annule l'opération et ferme la fenêtre.


Préférences du décompilateur
ASR partage le même moteur de décompilation qu'ASV (Action Script Viewer). Bien qu'ASV offre une fenêtre permettant de changer les préférences du décompilateur, ASR non.

Vous pouvez changer les préférences du décompilateur d'ASR en éditant le fichier ASR10.INI file. Vous pouvez aussi copier la section "Preferences" de votre fichier ASV31.INI file, si vous avez ASV et que vous avez déjà réglé vos préférences.

Voici la liste des préférences qu'ASR supporte :

SaveCompressed
Si désactivé, ASR sauvegardera tous les fichiers en mode non compressé.

MaxCompress
Si activé, ASR sauvegardera les fichiers compressés avec l'option 'Compression maximale'. Notez que ceci n'est pas d'une grande utilité la plupart du temps.

EnableASNativeComments
Si activé, ASR affichera les commentaires ASNative.

EnableOtherComments
Si activé, ASR affichera d'autres commentaires.

DontUseEval
Si activé, ASR n'encadrera pas les noms de variables invalides avec des commandes eval.

SafeASImport
Si activé, ASR essaiera d'éliminer certaines données invalides insérées par certains brouilleurs.

DisableActLenAdjust
Si activé, ASR sera capable de décompiler certains fichiers SWF masqués par un brouilleur populaire.

SupressErrorLog
Si activé, ASR n'affichera pas le journal des erreurs même s'il y a des erreurs dans un SWF.

MXColors
Si désactivé, ASR utilisera l'ancien style de surlignage de syntaxe d'ASV.

UppercaseRes
Si activé, ASR essaiera de corriger certains scripts utilisant des mots réservés comme variables.

DEBUGACT1
Si activé, ASR affichera les adresses bytecode à côté des ActionScript décompilés.

DEBUGACT2
Si activé, ASR affichera les données ActionScript en P-code. Sinon les données seront affichées dans un format Flasm plus lisible.

EnableAsrtemp
Si activé, ASR ajoutera une variable temporaire dans les rares cas où cela est nécessaire.

tempstring
Le nom de la variable temporaire pour la préférence ci-dessus est asrtemp. Vous pouvez changer le nom de cette variable ici.


À propos
Action Script Replacer 1.02 (27 Juillet 2003)

Éditeur
Burak KALAYCI (burakk@buraks.com)

Crédits
Consultant de production : Burak KALAYCI (burakk@buraks.com)
Programmeur en chef : Tolga KALAYCI (tolga@buraks.com)

Copyright © 2003 Manitu Group, Istanbul, Turquie.

Remerciements
Urami (urami_@FlashFugitive.com)

Version Française
Copyright © 2003 New Dimension FR - Benjy (benjy@newdimension-fr.net)

Historique
2003 27 Juillet | Version 1.02
2003 2 Mai | Version 1.01
2003 12 Avril | Première version (v1.00)

Contacts
Page d'accueil d'ASR : http://www.buraks.com/asr
Page d'accueil de Manitu Group : http://www.manitugroup.com
E-mail de contact: asr@buraks.com
E-mail de support : support@buraks.com
Forum de support : http://www.flashdecompiler.com
E-mail de liste de souhaits : wishlist@buraks.com (for new feature requests)
Adresse postale : Rihtim Cad. Izzettin Sok. 3/1 Kadikoy / Istanbul TURQUIE

Macromedia est une marque déposée de Macromedia, Inc. Les autres marques sont la propriété de leurs détenteurs respectifs.

Aide d'ASR 1.x révision 1.02


Contrat de licence utilisateur
CONTRAT DE LICENCE UTILISATEUR FINAL POUR LE LOGICIEL "ACTION SCRIPT REPLACER" DE MANITU GROUP

IMPORTANT-À LIRE ATTENTIVEMENT : Le présent Contrat de Licence Utilisateur Final ("CLUF") constitue un contrat entre vous (personne physique ou personne morale unique) et MANITU GROUP pour le logiciel identifié ci-dessus, qui inclut des programmes d'ordinateur et est susceptible de contenir des supports associés, des documents imprimés et de la documentation "en ligne" ou sous forme électronique (le "LOGICIEL"). En installant, en copiant ou en utilisant le LOGICIEL, vous reconnaissez être lié par les termes du présent CLUF. Si vous êtes en désaccord avec les termes de ce CLUF, vous n'avez pas le droit d'installer ni d'utiliser le LOGICIEL ; vous devez, cependant, le retourner là où vous l'avez acheté pour être intégralement remboursé.

LICENCE DU LOGICIEL
Le LOGICIEL est protégé par des lois et des traités internationaux sur le droit d'auteur, mais aussi par des lois et des traités sur la propriété intellectuelle. Le LOGICIEL est licencié, pas vendu.

OCTROI DE LICENCE
Ce CLUF vous concède les droits suivants :
·Logiciel applicatif. Vous pouvez installer et utiliser une copie du LOGICIEL, ou n'importe quelle version précédente pour le même système d'exploitation, sur un seul ordinateur. L'utilisateur principal de l'ordinateur sur lequel le LOGICIEL est installé peut réaliser une seconde copie pour son usage exclusif sur un ordinateur portable.
·Utilisation stockage/réseau. Vous pouvez aussi conserver ou installer une copie du LOGICIEL sur un périphérique de stockage, tel qu'un serveur réseau, utilisé uniquement pour installer ou exécuter le LOGICIEL sur vos autres ordinateurs dans le cadre d'un réseau interne ; cependant, vous devez acquérir et dédier une licence à chacun des ordinateurs sur lequel le LOGICIEL est installé ou exécuté depuis le périphérique de stockage. Une licence du LOGICIEL ne peut pas être partagée ou utilisée simultanément sur différents ordinateurs.
·Conditions d'utilisation. Vous ne pouvez utiliser ce logiciel que sur des fichiers dont vous avez l'autorisation de voir les informations fournies par le LOGICIEL.

DESCRIPTION DES AUTRES DROITS ET LIMITATIONS
·Limitations sur le Reverse Engineering, la Décompilation, et le Désassemblage. Vous vous engagez à ne pas décompiler, désosser, ou désassembler le LOGICIEL, excepté si une telle activité est expressément permise par la loi en dépit de ces limitations.
·Séparation des Composants. Le LOGICIEL est licencié en tant que produit unique. Ses composants ne peuvent être séparés pour une utilisation destinée à plus d'un ordinateur.
·Location. Vous vous engagez à ne pas louer, prêter à bail ou accorder de sous-licence du LOGICIEL.
·Résiliation. MANITU GROUP se réserve le droit de résilier ce CLUF dans le cas où vous ne respecteriez pas les termes et conditions de ce CLUF. Le cas échéant, vous vous engagez à détruire toutes les copies du LOGICIEL ainsi que tous ses composants.

DROIT D'AUTEUR
Tous les titres et les droits d'auteurs relatifs au LOGICIEL (notamment ceux afférents à toute image, photographie, animation, élément vidéo ou sonore, musique, texte et mini-application intégré au LOGICIEL), à la documentation imprimée qui l'accompagne, et à toute copie du LOGICIEL sont détenus par MANITU GROUP ou ses fournisseurs. Le LOGICIEL est protégé par des lois et des traités internationaux sur le droit d'auteur. De fait, vous devez traiter le LOGICIEL comme tout autre matériel protégé par le droit d'auteur, excepté que vous pouvez installer le LOGICIEL sur un ordinateur unique si vous conservez l'original uniquement à des fins de sauvegarde ou d'archivage. Vous n'êtes pas autorisé à effectuer des copies de la documentation imprimée qui accompagne le LOGICIEL.

DIVERS
Si vous avez des questions concernant ce CLUF, ou si vous désirez entrer en contact avec MANITU GROUP pour quelque raison que ce soit, veuillez nous contacter à support@buraks.com

GARANTIE LIMITÉE
AUCUNE GARANTIE. DANS LA MESURE MAXIMALE PERMISE PAR LA LOI, MANITU GROUP ET SES FOURNISSEURS REJETTENT TOUTE AUTRE GARANTIE, EXPRESSE OU TACITE, Y COMPRIS, MAIS SANS RESTRICTION, LES GARANTIES TACITES DE COMMERCIALISATION, DE CONVENANCE À UN USAGE PARTICULIER, OU D'ABSENCE DE CONTREFAÇON, RELATIVEMENT AU LOGICIEL, ET L'APPORT OU NON DE SERVICES D'AIDE. CETTE GARANTIE LIMITÉE VOUS DONNE DES DROITS LÉGAUX SPÉCIFIQUES. VOUS POUVEZ AVOIR D'AUTRES DROITS, QUI VARIENT D'ÉTAT/JURIDICTION EN ÉTAT/JURIDICTION.

LIMITATION DE RESPONSABILITÉ. DANS LA MESURE MAXIMALE PERMISE PAR LA LOI, EN AUCUNE CIRCONSTANCE MANITU GROUP OU SES FOURNISSEURS NE SAURAIENT EN AUCUN CAS ÊTRE TENUS RESPONSABLES DE PRÉJUDICES DIRECTS, INDIRECTS, SPÉCIAUX, FORTUITS OU INDUITS (Y COMPRIS, MAIS SANS RESTRICTION, LA PERTE DE CLIENTÈLE, L'ARRÊT DE TRAVAIL, LA PERTE D'INFORMATIONS, OU TOUTE AUTRE PERTE D'ORDRE COMMERCIAL) DÉCOULANT DE L'UTILISATION OU DE L'INCAPACITÉ D'UTILISATION DU LOGICIEL OU DE L'APPORT OU NON DE SERVICES D'AIDE, QUAND BIEN MÊME MANITU GROUP AURAIT ÉTÉ INFORMÉ DE L'ÉVENTUALITÉ DE TELS PRÉJUDICES. LA RESPONSABILITÉ TOTALE DE MANITU GROUP POUR TOUT PRÉJUDICE DIRECT NE POURRA EXCÉDER LE MONTANT LE PLUS ÉLEVÉ DES SOMMES SUIVANTES : LA SOMME PAYÉE PAR VOUS POUR L'ACHAT DU LOGICIEL OU CINQ DOLLARS US (U.S.$5.00) ; CERTAINS PAYS N'AUTORISANT PAS L'EXCLUSION OU LA LIMITATION DE RESPONSABILITÉ, IL SE PEUT QUE LES LIMITATIONS CI-DESSUS NE VOUS CONCERNENT PAS.